Page tree
Skip to end of metadata
Go to start of metadata

In Usage Engine 2.1.2, there are the following known issues:

Vulnerabilities in Linux

A number of vulnerabilities have been detected in the Linux packages in the platform images. These are all fixed in the upcoming minor 2.2.

Vulnerability in Snakeyaml

A vulnerability was detected regarding snakeyaml. This issue is fixed in the upcoming minor 2.2.

mzcli Commands Do Not Provide Return Codes

If you are using scripted solutions requiring return codes, you must use the mzsh commands, since the mzcli commands do not provide return codes.

mzcli Commands wflist "-not-member-of-wfgroup" not working on Classic  Usage Engine

Mzcli - wflist - '-not-member-of-wfgroup' throws exception on classic Usage Engine installation.

Pico Details Not Entirely Correct

When looking at pico details, either in the Web Interface or in the Pico Viewer, the details may not be entirely correct regarding number of CPUs and IP address.

OpenAPI Validation Error for Type enum

There is a bug when performing OpenAPI validation for parameters of the enum type. The bug is based on:

The error is recorded as:

Error(s) during request validation:

Unable to parse JSON - Unrecognized token'xxx': was expecting (JSON String, Number, Array, Object or token 'null', 'true' or 'false')

This occurs when you send a request to an NRF server that is configured using our HTTP2 Server agent with OpenAPI validation enabled. You will be meet with a Bad Request error (Error 400) and the validation fails. There was an issue with the specifications for the type enum within the 'anyOf' section as seen from the example below.

Example: NFType found in TS29510_Nnrf_NFManagement.yaml

      description: NF types known to NRF
        - type: string
            - NRF
            - UDM
            - AMF
            - SMF
            - AUSF
            - NEF
            - PCF
            - SMSF
            - NSSF
            - UDR
            - LMF
            - GMLC
            - 5G_EIR
            - SEPP
            - UPF
            - N3IWF
            - AF
            - UDSF
            - BSF
            - CHF
            - NWDAF
            - PCSCF
            - CBCF
            - HSS
            - UCMF
            - SOR_AF
            - SPAF
            - MME
            - SCSAS
            - SCEF
            - SCP
        - type: string

A workaround would be to add the 'type: string' parameter on the same level as the 'anyOf'.

Encrypted Dynamic Workflows Uneditable in Web Interface

It is recommended not to use or create an encrypted dynamic workflow as you will not able to make any changes to the workflow in the web interface. 

Importing Old Configurations with Web Services Using Keystore Requires Additional Configuration

If you have an old webservice configuration from 8.x that uses keystore then the existing Security profile will be empty and to use a Security profile, you need to create a new one. This also applies to Diameter if it uses the Security profile.

The mzcli Command 'disconnect' is not Working on Containerized Solutions

When running the disconnect [hide]mzcli[/hide][hide]10.6[/hide] command in a containerized solution the ECD will unexpectedly terminate.

The property for limiting password changes needs the property "reset.enabled" to be set


Settings for the platform, values.yaml:

    - mz.user.account.change.password.limit=true

Usage Engine terraform template does not support M1 Mac with darwin_arm64 architecture

The setup files for AWS installation does not contain a provider that supports the new M1 Mac darwin_arm64 architecture.

The error is recorded as:

➜ terraform terraform init
Initializing the backend...

Initializing provider plugins...

Finding hashicorp/aws versions matching "~> 2.0"...
│ Warning: Version constraints inside provider configuration blocks are deprecated
│ on line 5, in provider "aws":
│ 5: version = "~> 2.0"
│ Terraform 0.13 and earlier allowed provider version constraints inside the provider configuration block, but that is now deprecated and will be removed in a future version of
│ Terraform. To silence this warning, move the provider version constraint into the required_providers block.
│ Error: Incompatible provider version
│ Provider v2.70.1 does not have a package available for your current platform, darwin_arm64.
│ Provider releases are separate from Terraform CLI releases, so not all providers are available for all platforms. Other versions of this provider may have different platforms
│ supported.

Known Vulnerability CVE-2019-10797 when Using Netty 3

When using Netty 3 there is a known vulnerability (CVE-2019-10797 according to NIST) and the solution and workaround is to use Netty 4.

In other words, the known vulnerability (CVE-2019-10797) does not affect you if you are using Netty 4.

To be backward compliant in terms of performance requirements, it is not feasible to remove Netty 3 from MediationZone at this point. Mzcli - wflist - '-not-member-of-wfgroup' throws exception on baremetal

XE-4859 Mzcli - k8s - disconnect causes ecd to be killed Not possible to use terraform on a new Mac with darwin_arm64 architecture mzonline workflow throws error when I have encrypted wfs terraform template does not support M1 Mac with darwin_arm64 architecture Vulnerabilities in Linux Vulnerability snakeyaml

  • No labels